• jan@cosmigo.com

Collection of Small Bugs and Useability Problems


#1

After Using 7.1.7. pretty extensively I have noticed a few things. I don’t know if all of them qualify as “bug”.

Undo Hangup
Once in a while when using the Undo-command it starts to hang in a undo loop, basically undoing the whole image. It cannot be interrupted. What you can do to workaround the issue is to hold down the keyboard shortcut for redo until you arrive at the latest point and then press the shortcut for save project. Most of the time PM will crash after that. It happens very frequently. At least once a day.

Tablet Problem With Wacom ISD-Tablets
The bug was introduced with the fall creators update and happens with Wacom ISD Digitizers. Not the wacom tablets, but anything that uses the, pretty shoddy, Wacom Feel driver. When starting a pixel stroke there is a small “deadzone” before windows registers the stroke. After crossing the border the stroke instantly jumps to the registered point outside the deadzone in a straight line. Since the deadzone is pretty extensive, especially when zoomed out, it often results in a stroke that is not like intended. And it prevents small strokes when above a certain zoom level. I have tracked the problem to be based on how windows handles touch. It waits for the touch to get outside of the deadzone to check for flicks etc. The feel driver does not have the feature to disable Windows Ink (like the regular tablet driver from Wacom) which would solve the problem. However, There are several Programs, like Autodesk Sketchbook Pro and Photoshop that register themselves as application to not use those features.

I have tracked the problem down to one registry key
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\PenService
Look for the corresponding subkeys. Matching seems to occur via UIDs
All the aforementioned software Packages register themselves here. But I literally have NO IDEA how to do that manually ^^ I know it’s quite a niche problem, but if Pro Motion would register there I think the problem might go away entirely.

I can provide a video of the problem if needed or show it live via sreenshare.

Dither Option not working on any other tool than Paint
I don’t know if this is intentional or not. However, activating the Dither Option in “Tool & Paint Settings” doesn’t do anything for any other paint tool than Paint. This worked in the past, so I assume it might be a bug.

Dither On/Off Shortcut missing from Keyboard Shortcuts
Worked in the past. Was quite useful ^^ Now it’s gone :smiley:

That’s everything from me. If I can help out with any additional data, let me know! And thanks for making that awesome software once again :smiley:


#2

I somehow missed this post :frowning: Thanks for the report…

Undo Hangup
Can you please send the crash report that appears? This should help to locate the problem.
Also, there are shortcuts that undo/redo everything: Ctrl + U and Ctrl + I.
Was not reported from other users yet.

Tablet Problem With Wacom ISD-Tablets
Thanks for this hint. Will read some docs about that and register there.

Dither Option not working on any other tool than Paint
Can’t duplicate. Tried line, circle, filled/unfilled, flood fill.

Dither On/Off Shortcut missing from Keyboard Shortcuts
Fixed with 7.1.8


#3

Hi Jan! No worries ^^ Glad you take a look!

Undo Hangup Thank you for the info. I was totally and accidentally hitting the “undo all” button! My bad. Never noticed the shortcut. So that was a very useful information that totally fixed the issue for me. ^^’ Embarrassing

Dither Option I tried the dither option yesterday and it seemed to work on everything but the filled rectangle tool. I thought I had tried the other options, but I think I might just have assumed that they didnt work too. Sorry about that. I just double checked on two machines and the “Filled Rectangle” Option produced a solid color, whereas the “Filled Circle” for example produced a proper dither pattern.


#4

Hi Richard,

just tried the dither problem and this is already fixed but not published. It was fixed with the fill tool not using dither. It was the same problem source. If everything goes well then 7.1.8 (maintenance release + Mac/Linux version) will be published tomorrow.

-Jan