Grid and Brush Snapping issue

Ive setup a new project which uses 8x8 tiles. I`m using an 8x8 grid for snapping so that I could grab tiles using the “Rectangular Brush Grab Tool” However when I use the tool to grab a tile the selection shows as 9x9 pixels not 8x8.

Welcome to the community!

I tried reproducing and tested your case here:
rectangular brush test

Test params:

  • Tile Map project
  • 8x8 tiles
  • 8x8 pixel grid
  • grid snap, on
  • rectangular brush tool
  • PMNG v8.0.4.0

On the upper left part of the canvas:

  • drew on a 3x3 grid
  • for the center tile, filled all corners with pixels
  • outside the center tile, drew a single pixel line to see if the rect brush grab tool catches it. In the test demo, it didn’t.

I couldn’t get the same results. My test params might’ve been different from yours.
Can you show us a demo how it’s happening for you?

If the .gif demo above is too small for you, you could right-click on it and select “Open Image in New Tab”.

Hi @Veedub,

generally picking up tiles is done when being in tile mapping pick place mode. In that mode it will always snap to the full tile sizes.
When being in “Modify/Create Tile” mode then you typically draw without using a snap grid, but there might be cases when you indeed want to modify complete tiles.
In the “Modify/Create Tile” the standard grid snap options apply as with any other non-tile map project and they look like this:

Please notice the “Inbound” option. If this is off then any tool would just snap to multiples of the grid sizes, in our case 0, 16, 32…
If it’s off then the tools snap to the inner bounds of the grid… 0, 15, 16, 31…
So, in your case I guess that this option is off.

Hope this helps.


1 Like

Sorry its been a while but thankyou for this. It solved the issue.