Grid layer always made visible


I’m using a custom grid layer consisting of two boxes (8x8 and 16x16), which I show/hide via a shortcut (Alt-G).

The issue I’m having is that when I activate the grid lock (shortcut G) a default 8x8 grid layer is always made visible. Worse yet, I can’t toggle it off while the grid lock is enabled.

Is this the expected behaviour? I think ProMotion 6.5 got it right: enabling the grid lock should not force the display of any grid layer. These should be two independent actions altogether.


The grid display for the lock grid is an addition helping those who only need a simple grid to align to.It is an option and can be disabled here:

Jeez, that was pretty obvious - my bad!

Thanks Jan