How to change pixel brush shape? (resolved for v8.b8)

Before, when upsizing the brush, it’s a solid circle.
Now, it’s a square.

I like that we can change between shapes now (more options! Yay!), but how do i change it to circle? Rather, where do i change between those states?
I can’t find it in the UI.

If there’s no UI for it yet, can we have it here?

PMNG v-8b.7

By default the single pixel brush is a circle. So, Shift + + will create a circle.
Reset to single pixel using “.” key (period).
Different brush tips can be found here as well as the single pixel brush as square:
Shortcut for this is Shift + “.”.

Thanks Jan! Found it. The shortcut keys are working. But for the interface, it seems to have only worked once.
I tried restarting PMNG, on existing projects, as well as on a new project, and the result was the same.

I think what i did was (in an existing project):

  1. clicked on the UI button (worked, the context menu popped out)
  2. clicked somewhere else randomly, outside the context menu to close it. - Here’s the part that’s fuzzy, i can’t remember if i clicked somewhere else randomly or pressed the ‘esc’ key.
  3. Tried clicking on the UI button again. (wouldn’t work now)

Here’s a demo from a new project:

Hi @cageburner,

you need to hold the left mouse button for 0.2 seconds before the context menu opens because the button has two functions: use the brush tip that the button currently has (simple click), hold longer to open the brush tip menu.
It’s the same as it works for the buttons in the tool box, but…
in the tool box also RMB opens the menu immediately. This is not the case with the brush tips, it also opens there only if you hold RMB longer. I will change this, because it’s not consistent.


RMB started the brush resize mode. I removed this for the sake of consistency so that with V8 beta 8 RMB it opens the context menu instead. Let’s see if there are complains from other users :no_mouth:

I tried it and it works exactly how you said it.

Yeah, i guess it is a consistency issue cause i’m not aware of any tool i use in PMNG where i needed to click and hold a button for it to show a context menu or anything else.

Thanks Jan!