• jan@cosmigo.com

Keyboard key "f3" key doesn't work?

Env:
Win 7, 64 bit
PMNG ver. 7.2.7.0

desc

Midway while drawing, for some reason, The “f3” key alone doesn’t work anymore? It was working one second ago and didn’t the next.

Using modifiers such as “Alt” or “Ctrl” works, every shortcut in the screenshot below works.

Except plain “F3”.

troubleshooting

I tried to restart just the program, and the whole OS next but both didn’t solve the problem.

I checked in other programs if the keystroke registers, and it does. All function keys work properly, except “F3” inside PMNG.
I also plugged other keyboards. I tested it on 3 keyboards. And all of them had the same behavior, so i know it’s not a hardware issue.

I heavily use Formula mode so i swapped it with Brightness. The obvious workaround is to swap the shortcut keys back. But then, that means I’d be stuck with pressing 2 buttons instead of one to change modes, which was the reason i swapped them in the first place.

halp?
This is a really weird case. Could i have hit a super secret shortcut that made “F3” unusable? Is it something i did with windows?

Quick update.

So i used this online kb checker to see how the keystrokes are registering.

At the bottom right, it knows that “f3” is being pressed.
But we could see at the upper left that something else is happening. It looks like i am missing a state?
I think it’s “keyDown”. The checker seems to detect when “F3” is on “keyUp”.

When i press and hold a key in this kb checker, it stays grey until i release it before it turns green. This is true for all other keys except “F3”, where it’s just green all the way.

So, this is really weird, if this is a hardware issue, that means, all 3 keyboards tested have the same issue with issuing their keystates? Or did windows did something in my bg without me knowing? Because i was in the middle of drawing when this happened.

I just realized while typing this right now, but i could just re-assign ‘formula’ mode to or “f5” some other default that i don’t really use. :man_facepalming:

My only request to @jan.cosmigo is that if it’s not too much of a hassle, maybe insert a check for a keyState too, when accepting keyboard presses?

I’m still weirded out by what happened here though. I wish to have my “f3” back. :sob:

Then the problem might be with the PC hardware. Unless these are all PS2 keyboards, you should try changing USB port. Another possibility is that there might be a keyboard-like device (software or hardware) interfering with the keyboard.

I’ve found this free tool to check for Windows associate shortcuts:

https://www.rjlsoftware.com/software/utility/shortcutkeys/

(NOTE: I didn’t test it, I’ve never used, I just saw it mentioned on some forums discussing similar problems)

The only thing that comes to mind that Win 10 could do while working with the keyboard is enabling Filter Keys:

which is a rather annoying feature that can easily be triggered by holding the Shift key down for too long. I had to disable this feature because it was interfering with my daily typing.

If it’s none of the above I have no other idea what it might be…

This would be a rather useful feature IMO, for it would allow to check from PM’s setting panel that drawing tablets which can programmed to send key presses are sending correct signals to PM (e.g. Waco’s extra side buttons, etc.). Often keyboard like devices don’t work as expected under Win 10 due to driver and/or locale settings conflicts, especially after Win updates. So being able to check keyboard shortcuts directly inside the receiving app is the safest confirmation.

Thanks man! I’mma check out your recommendations right now. :slight_smile: