Line Draw Keyboard shortcut ALWAYS cycles different tools

What the heading says… No matter how I try to define the keyboard shortcuts, pressing the tool key for line draw mode, always cycles between curve, poly, etc. This behavior seems to be unique to the line draw tool even if unique keyboard short cuts are defined for the subtools like curve, repeatedly pressing those controls doesn’t cycle the tool type.

This is undesirable especially if the subtools like curve and poly are rarely used

Can’t duplicate. Can you show the settings?
For testing I just used:

V now cycles through line and curve.

Ok Jan, I have just tried and have narrowed it down. It appears that if all the sub tools are assigned to different keys then the “main” Line command doesn’t cycle. For instance here:
“V” in this case is locked to line draw (for me this is preferred)

However if I remove the shortcuts for the sub commands it does cycle. This also seems to apply to the Rectangle tool (remove the filled rectangle key)

So, this looks to me that this is by design and can be worked around… my own preference would be to not have the cycle behaviour for a frequently used key (because I have to waste possible keys for the extra tools)
but I am now fairly confident this isn’t a bug… hope you haven’y wasted too much time getting this to repeat

What you describe is how it works with V7. There the “main” shortcut which is the one of the first tool in a group is used to cycle through all tools having no shortcut assigned.
You can switch this of in the Preferences, btw.

But with V8 it works differently. There you can assign the same shortcut to tools of a tool group. It then cycles through the tools only that have assigned the same shortcut. This is better than the V7 solution.
Can you please check if the V8 beta works for you as I just described? Want to be sure that there isn’t a bug or some scenario that I missed.

Ok, this is weird. I tried V7 first and found the option in preferences… and it didn’t seem to do anything for me. However, I had no commands set up for the the sub tools in the group so it didn’t cycle through the tools when I set the preference [when holding the mouse over the line tool selector- the V key is only set to the top tool] However, as soon as I set up a command for curve (ALT+V) the cycling worked (with the preference set to on) and the V key was assigned to all other line tool functions. see image image
None of this was an issue for me before because I think the default for the cycle tool preference was off.

In V8, things are slightly different. I deselected the option to cycle first and I am happy that the cycling doesn’t happen any more. However the tool selector shows the V key assigned to all functions, even though it doesn’t cycle.
Moving on from this and hopefully answering your question: I reactivated the cycle grouped tool preference and made sure that V is the only key assigned to Line (with no keyboard commands set up for curve, etc) and pressing V now cycles through all the subtools.
I added a key for Curve. Now pressing V only cycles through Line- Polygon- Filled Polygon

I checked to see that deactivating the Cycle grouped tools preference still works and it does. (phew)

Finally, I tried setting the same keyboard command for Curve, Polygon, etc and logically, it only allows one keyboard command to be set for a single command.

In summary, I think everything works as intended, and thanks to the cycle grouped tools preference I am happy that I can set a key to work predictably.

Thanks for digging into it. When reading your lines I was even more confused and I now know why :slight_smile:

When you are talking about V8 then you mean the V8 Beta 1, but there is a newer V8 Beta 2 and with this latest Beta 2 there is no preferences setting for cycling the tools anymore.
There it works as I described: you can set up the same shortcut for tools in a tool group. Then and only then the cycling is done for all the tools sharing the shortcut:


That is VERY strange- just checked I am was actually testing the V1 beta. Sorry about the mix up. Dloaded V2 and it seems to work really well :slight_smile: