Move tool issues (resolved for v8.b8)

Move tool auto selects layer even when unchecked.

  • Move tool will select a layer and execute it’s function then continue to stay there in that layer.

The ff ss shows the checkbox i’m talking about

There is no way to click on the available buttons for the move tool.

  • When we use the move tool, we click and drag on the canvas, once we release the mouse button, those buttons disappear.

The ff ss is taken while holding the LMB:

Holding shift will lock to the x and y axis.

  • I’m not sure if this is an intended behavior, but i tried to hold shift while using the move tool and it didn’t lock with either the x or y axis. If it was intended to be that way, disregard.


Hi @cageburner,

with my current dev version the layer move tool respects the “Auto select” layer option. Also there is a new mode. You can hold Shift and click (without drag) to select multiple layers.

There is no way to click on the available buttons for the move tool.
When you have no selection then the move tool does not turn the moved element to a floating selection. Instead the movement is finalized. That’s why the button appear when you move it and then disappear again. It’s kind of technical side effect.
If you have a selection then it’s turned into a floating selection and then the buttons stay.

Locking with Shift is a good point. Added to my list.


Thanks for the response, Jan!

Tried making a selection first before using the move tool and it worked exactly how you said it.

The ff is a gif of what i was talking about with the ‘Auto select layer’ option of the Move tool. First 3 uses here are with checked, next 5 are unchecked, then checked again. Checked or unchecked, same effect:


With V8 beta 8
Auto selection is working as well as multiple selection with Shift
layer selection

1 Like