• jan@cosmigo.com

Option to offset color index when loading palette files


#1

Edit: NVM. I’m stupid. I created another new project just now and had a sudden urge of curiousity in one of the fields: Transparency.

I checked the options in the dropdown and found “Pallete Entry:” It was set at ‘0’. So i’ve tried changing it to ‘255’. And guess what? All my problems are solved. :man_facepalming:

image

Leaving it here anyway just in case someone else finds themself in a similar situation.


PMNG ver 7.2.7.0

No matter what color is set on index 0 in PMNG, it will paint transparent pixels / erase pixels. Issue is, most palettes, if not made in PMNG, it’s 0th index has color data in it. So we gotta do a couple extra steps to workaround the issue.

The workaround is easy, it’s just…not very QoL-friendly, to have to do these extra steps everytime when loading a palette.
The workaround is:

  1. First, in the edit palette section, make sure you have “Select linear Range” or “Select rectangular Area” selected. As well as “Move Colors when Dragging”.
  2. Select all indexes with colors in them.
  3. Drag selection where at least the start of the palette is index 1.
    Next, either:
  4. Create a new layer
  5. Delete the default ‘Layer 1’ layer.
    Or:
  6. Select index 0 in the color palette, Select Fill tool.
  7. Fill the canvas
  8. You can now start working on the new project.

Steps 4-5 is needed because after dragging the palette so there is no color set in index 0, Layer 1 will be filled with whatever color index 0 had.

I’m guessing there is an edge case where setting color data in index 0 has it’s special use, allowing us to meddle with it?
If so, i wish to have an option so we could offset loaded palettes to start writing at our desired index. In my case, almost 100% of the time at index 1.

Sample loaded palette (isas-true-master-palette)
image