Painting a brush grabbed tile on an edge tile is offset (resolved for v8.b8)

When painting a brush grabbed tile on the top tile, it’s offset to 1 pixel up. Therefore, the bottom pixels of the tile are missing.

Edit: Found out that it also happens on the left most tile. Painting with the grabbed brush when Grid snap is on and/or when we Pick/place Tiles will offset it to 1 pixel to the left, making the right most pixel of the tile be left transparent.

Tilemap project
5x5 32px tiles

Brush handle: irrelevant. Tried all, same effect.


  1. Draw on the center tile, be sure that the top and bottom ends of the tile is drawn on too.
    • Select Pick/place Tiles
  2. Select Rectangular Brush Grab Tool
  3. Grab the tile we just drew
  4. Paint the top and bottom most tiles
  5. See the discrepancy

** Results the same even when in “Modify/create Tiles” and Grid Snap is on.


beta ver

Not sure if the same issue. But more case demo.
The distinct factor here is that Grid snapping is on.

In this demo, we first grab the tiles in ‘Pick/place Tiles’ mode. (working)
After, we grab the tiles in ‘Modify/create Tiles’ mode. (buggy)


PMNG v8.b7

Cage, I can’t help you but kudos to your work your a really great artist!

1 Like

Hi @cageburner,

was not able to duplicate. Is it possible that you create a true video so that I can see all the settings? In the animated gif certain details are impossible to see.


Thanks Morintari, I appreciate your kind words!

Hi @jan.cosmigo ,
I could just mail the files where this is happening.

Hi @cageburner,

thanks for the files! I also noticed that your gif recording is shown downscaled in the thread. When opening it in a new tab, then I can perfectly see everything.
Unfortunately I still can’t duplicate this despite of loading and using your project. Will have to play around and maybe I ask back via email if I can’t make it happen here.


Hi @cageburner ,

right after my last post I examined the settings of the brush pick tool…

You have “trim” enabled. This reduces brush size to minimum opaque pixels. I’ll include a warning here because this can obviously get confusing in combination with the grid. Or I maybe just ignore the setting if grid snap is enabled.


With V8 beta 8 the trimming option is silently ignored if grid snap is enabled.

Thanks Jan!

I tried un-ticking trim myself and it worked like a charm. Glad that was resolved!