Phantom Draw Pan & Zoom Undo Bug


This really strange bug is on version of Pro Motion NG.

Somehow, you can get a Phantom Paint Tool brush going, by using middle mouse button. Believe it or not, I Pan and Zoom a lot with middle mouse button (both by clicking and by scrolling) and have this happen to me quite a bit.

Here is a video showing-off the bug. Not really sure how to explain things better, but I do have my mouse and some keyboard inputs shown on the screen in this video:

Hi @Zeralith ,

the middle mouse button is by default set up like this in the preferences:

(“LEER” means “Space”. The dev system I use ignores some settings and uses German on my system although it’s set up to use “English” :roll_eyes:)

What it internally does (or should do) is:
Simulate the key stroke of “Space bar” and then apply a left mouse button click which will activate the canvas mover and let you move it until you release. Then it should release the mouse button and also release the space bar.

What I see in your video is like it sometimes does not execute the space bar but registers the left mouse button click and when you release the mouse button it does not release it. So, you effectively start the drawing operation and never finish it. This can be seen that when you move the mouse off the canvas at the end, then it’s still drawing. Because the drawing is not finished, no undo record is created and you undo/redo the previous actions.

I was not able to make this happen, but I will try to figure out why this could happen and try to fix it. Since I can’t duplicate it (yet), I might come up with a patch for you to test, hoping that you can help me to check a possible fix.


Hi @Zeralith,

still I could not make it happen and also examining the code that is responsible and poking around with it did not help me to understand what’s happening.
Does also happen when you are not using the mouse wheel to change the zoom level by just clicking around with the middle mouse button and moving the mouse?

Does it maybe happen when you do a kind of double click with the MMB? Normally double clicks should only fire a “double click” event for the LMB, but maybe with your system it also works for MMB?


Hi Jan,

That’s unfortunate you haven’t been able to reproduce it yet.

I can’t seem to make it happen when double clicking middle mouse button. It’s almost like it just happens randomly while trying to Pan, but also accidently Zooming at the same time. It’s difficult to replicate, but comes-up often enough for me just when I’m Panning normally.

It’s almost like if Panning and Zooming happen at the same time, it’s like a 25% chance that the virtual Spacebar gets stripped-out of the inputs. Maybe try Panning and Zooming like a madman, using only the middle mouse button + scroll, to see if you can reproduce it?

Maybe to fix it, you could disable Zoom when Pan (Middle Mouse Button) is active/held and only allow Zoom again when Middle Mouse Button is released?

Here are my mouse settings (“Scroll Click” is “Middle Mouse Button” in all other software, my mouse just calls it that):


And here are my Pro Motion NG 8 settings:

I hope you can somehow figure-it-out! Thank you! :pray:

Hi Zeralith,

thanks for all the detailed input!

Panning and Zooming like a madman

That’s what I did. Luckily no-one was watching me :smiley:

Indeed it could help to disable the zooming when panning is active.
If I still can’t duplicate (will try again like a madman) then I will send you a test patch.


Today I was able to get that effect, quite rarely but it appeared. I changed the system as you suggested. When middle mouse button is down, any mouse wheel action is skipped.
Tried to make the problem happen after the change. It did not appear, but I’m not 100% sure if this works generally. Will send you a patch to test separately.

1 Like