Pro Motion 6.5 vs NG

Hi there,

just installed NG today after upgrading from 6.5. I was really tired of white bg that was hurting my eyes in 6.5 and wished for a dark theme. Therefore I upgraded to NG, coz I thought it would fix my problem. With sight - yeah, relief. But then NG kept crashing.

I don’t know if it’s just me not knowing how to navigate through the program, but PM 6.5 was very intuitive one and NG feels like a much, much older version. Not only it frequently crashes when I try to re-arrange windows, it also seems to be deprived of some of the functions I was using on daily basis. Firstly, it is the mask. Right-click in 6.5 and I could create an easy and quick mask to recolor some of the project parts. Now, I can’t find any option like this. Why? Secondly, “grab frames as brush”. How do I make the brush to animate while drawing? Again this is over-complication of things. Thirdly, the workspace. I could maximize the window in 6.5 and arrange it as I please. NG doesn’t seem to have that option. Moreover, all the other windows keep popping up BEHIND the workspace if I don’t pin them. Right-click to the tools doesn’t allow me to change the settings of the tool - instead I have to get another window and sacrifice my workspace. Why? The solution in 6.5 was perfect, you just broke it! Not to mention that when I try to re-arrange the windows with the built-in tool, the whole program crashes. C’mon!

For now, I feel like NG is not for me. Do you offer a “refund” option?

I’d like to go through the problems with you.
Crashing and opening windows behind the main window are bugs that have not been reported yet, so I’d like to fix them but I need a crash report. The dialog that opens when the crash appears offers to send a report. Can you please do this.

Firstly, it is the mask. Right-click in 6.5 and I could create an easy and quick mask to recolor some of the project parts.

Yes, this has moved. You only need to go to the palette window. Under the edit tab (which hides different edit areas) you find a stencil tab to do this.
Also, hit “E”. Then you have a quick stencil tool to select (LMB) unselect (RMB) colors. Hit E again to switch off.
Both should be what you want to do. I understand that you did not find it. The change might be a bit rough for 6.5 user. But it’s interesting for me to know that. Maybe I find a way to make this more obvious.

_Secondly, “grab frames as brush”. How do I make the brush to animate while drawing? … Again this is over-complication of things. _
The same way you did it before. It’s just now called “Grab Frame Selection”. It grabs the frames that are selected in the time line. If nothing is selected then all frames are grabbed as it was with 6.5.

Thirdly, the workspace. I could maximize the window in 6.5 and arrange it as I please. NG doesn’t seem to have that option.
I don’t understand that. Can you please describe this a bit more?

Right-click to the tools doesn’t allow me to change the settings of the tool - instead I have to get another window and sacrifice my workspace.
I changed this because users didn’t like a bunch of different windows and I didn’t like it either. Everything has been combined into the “Tool & Paint Settings” window. Can you please describe why this is worse than before?
With future releases I also plan to add docking windows and to let the user also select one of those window tabs to be separate windows again. Then everyone should be happy.

Thank you,
Jan

P.S.: Of course you can get a refund anyway, but not before I got the crash report. Since it happens on your system regularly and I don’t know any other user where that happens. You are my only chance to fix it at the moment :slight_smile:

As discussed via email (and to update this thread):

Crash problem: fixed
It occurred when layer window AND brush container where set to invisible and the “arrange windows” function was used.

AnimBrush not animating: the “Rewind after drawing” option was enabled so the AnimBrush was rewound after every drawing step. Also there is a bug with the continuous drawing tool which skips a frame when drawing with an AnimBrush. Workaround: single dot tool.

"Also there is a bug with the continuous drawing tool which skips a frame when drawing with an AnimBrush. "

Fixed with 7.1.7