Pro Motion Crashing

When I open up Pro Motion NG and try to create a new file (Through the New Project Button or the menu, the software crashes immediately. When I first purchased the software, it worked great. I was then busy for a few months with other jobs. When I came back to try out Pro Motion, it does this all the time. I even uninstalled and reinstalled the software and it still does this.
I run Windows 10 on a PC I have made myself.
This happens on Version
This is what happens first (if the image uploads properly)

Then if I leave it be for a few minutes or try to click in the window, anywhere, it crashes like this…

How about uninstall, restart the PC, then reinstall?
If that doesn’t work, do the above steps again, but change "restart the PC" to "full shutdown, then power the PC back on".
What would happen then?

I tired both and I still got the same freeze, then blacks out all the outter window like the menu, etc (image 1) and freezing and shutting down on image two.

I had similar problems in the past due to incompatibility with a scanner driver (TWAIN):

might be worth looking into, even if you didn’t install new hardware in the meantime — the incompatibility might be caused by a driver update, e.g. an existing driver you installed or a driver that ships with Windows. Recently there have been a number of big Windows updates, many of which contain new drivers for MS devices, etc.

Oh man, serious?! I have no idea how I would go about starting that. I don’t have too much hardware installed. I’ll try updating my wacom driver at the very least. This was also happening on my laptop (which both I reformatted about a month ago).

I might just give up on using this software and stick to Aseprite. I wanted to try it out and see which I would like more of. I have never had these kinds of issues with any drawing software before so it’s a bit discouraging.

Hi @Brohmyr

can you please check if this also happens with V8 Beta?

There is no special thing with usage of special hardware in Pro Motion, but the development system I use of course does things under the hood that I can’t control.
With V8 I used a newer version of the dev system and the hope is that this effect is gone then.

Than you,

1 Like

I do not get the issue with the Beta version. Thank you Jan. It opens up fine.

1 Like