Problem with bitmap fonts (BUG)

hello Jan.cosmigo., I’m trying to make a custom bitmap font but everything is well until I go past period in the ASCII table then it misses one character Ive tried and Ive tried but I can’t seem to get it not to miss a character after period. If you want to test this Make a bitmap font from scratch and type up past period then for some reason it wants to miss a character.
please fix this when you can Jan.cosmigo thanks in advance any help is greatly appreciated.

P.S the bug won;t be present in pre existing bitmap fonts.

also I have noticed that most of the characters in ascii !@#$ ect… Are mapped incorrectly when exporting. also most of the uppercase characters. are mapped incorrectly as well.the. I think the nunmaric charicters might be mapped incorrectly but most of them show up correctly except the number 9. Please fix when you can.

I’m not sure what you mean exactly when you say that a character is “missed” — do you mean it’s skipped in the mapping process? (i.e. leading to an offset in the expected results?)

Beware that keyboards can be tricky, and that when working with non-USA keyboards the drivers often do some strange characters manipulation, so don’t give for granted that they key you press always results in the correct ASCII character being sent to the operating system — often there are encoding issues inbetween.

Using the numpad is not the same as pressing the equivalent keys on the main keyboard, and different language (locale) keyboard layouts produce different results. Many software which have default keyboard shortcuts that seem “normal keys” often don’t work in certain locale layout, because the operating system interface is more complex than just the “character” but actually takes in consideration the “key value”, which what makes it possible to treat the left and right SHFT keys differently, as well as the numpad keys differently from their counterparts on the main layout.

To test if the problem is with PM or your keyboard driver, you should try using the Windows on-screen keyboard (OSK) to carry out the same operations, and see how PM works with it:

if the problem persists with the OSK, then it’s a bug in PMNG, otherwise it’s a problem with the keyboard interface — which might be solved in different ways.

I have an Italian keyboard, and noticed that many of the default keyboard shortcuts don’t work for me, even if I have those keys on my keyboard — but these keys don’t have the same mapping as a USA keyboard, so they fail to work even if they should.

In my experience, being able to properly cover all the possible keyboard layouts is almost impossible, especially since many keyboards deviate from standards via custom drivers (e.g. gamers keyboards) or by extra tools they install to add custom functionality (e.g. to launch specific software via custom key combinations, etc.).

The best solution is when a software exposes to end users customization of all the keyboard shortcuts, via the settings panel. Usually, entering the key combinations using your own keyboard solves the problem, even when the keys involved seems the same as the default settings.

But the ultimate test is to use to On-Screen Keyboard, or to fiddle with the keyboard layout settings (e.g. telling Windows to treat your keyboard as a USA layout)…

Hi @Morintari,

can you provide a sample bitmap font file where the problems appear?
Also, you filed it as Beta feedback bug. It does not appear with the current production version 7.x?


hello Jan.cosmigo now when I try to make a sample bitmap font I get this message

So I can’t give you a finished font. however keeping that in mind I am sending the PNG in hopes that you can exstrapulate a font from that. Oh and BTW it does happen with the production version too,

Ok I found 2 places where I missplaced a character so that may account for the character skipping I don’t know anyhow that still does’nt account for the strange message I get when I convert it into a font. Let’s not worry about the character skipping just yet until we get that message under control.Oh and bttw thanks Tjamone for your help as well.

Hi @Morintari,

it’s important that the first top left pixel in the image is the indicator pixel that is used to separate the characters. Please place a red dot at the very top left. The first character after that is the exclamation mark etc… I copied your image to a new project, added the red pixel and (almost) everything worked fine:

There is a bug in the letter indicator at the canvas bottom. It does not show the “&” characted. I just fixed that.

I was not able to duplicate the error. Can give me more details about that? Maybe send the project by email along with some steps how to make it happen.


hello Jan.cosmigo thank you and Tajmone for your help on this matter. I sent you the files Via dropbox let me know if you get them.they are called “problems with fonts” there are 3 files to let you know what’s going on I hope this helps.