• jan@cosmigo.com

Saving to gif is problematic with effect layers


#1

When you save to a .gif file (i.e. an animation), bad things happen to a project that contains an effect layer (for example, soft light) on top of another layer.

What is happening behind the scenes, is that colors from the soft layer force a palette adjustment to accommodate colors that result from the overlap of the soft light layer on top of another layer. In an animated file, it can be a lot of colors.

Since the entire palette gets replaced, often one unfortunate color gets shoved into the color 0 slot. The program also makes that color transparent in the .gif file palette.

This is undesired.

Known workaround: flatten all layers and pray for an acceptable result.

Expected behavior: if color 0 slot must remain transparent, no used color gets shoved there when creating a new palette. Probably better to “lock out” that color as an option somewhere.


#2

Yes, this is a bug.
Another workaround: turn on alpha transparency, save, turn off alpha.


#3

This is now fixed with 7.2


#4

Uh, I seem to have not fixed this completely :tired_face: Will try again with the next maintenance release 7.2.2


#5

Your workaround works, but it’s still a pain point.

I just wasted a good hour trying to remember how to do it.

Please release the proper fix soon.


#6

Can you send a sample file so that I’m sure to also have fixed your problem? I could also provide a patch for you to check.