[SOLVED] Toggle Selection stays turned on after leaving Select tool (Fixed with V8 Beta 5)

First off, hi! I’ve started using Pro Motion NG thanks to a friend of mine and I gotta say, wow it has some powerful and useful tools for drawing pixel art!

I ran into a bug on the beta version where I stopped being able to draw, even if I was in Paint mode. After some messing around, this is how I reproduce it:

  • Start a new project; drawing works fine.
  • Enable the Rectangular select tool and select an area. Then unselect everything.
  • Enable any other drawing or brush tool and try drawing again.

In my experience, drawing no longer works, because the Toggle selection option in the toolbar stays toggled on after switching away from the select mode. It’s not immediately obvious that this is the case.

Using the beta on Wine (Steam Deck to be exact, though I’m not sure that matters).

Welcome to the forums!

I couldn’t reproduce your issue with the steps provided on my end. Whether it’s via shortcut keys or the UI.

Can you post a .gif animation when it happens on your end? I recommend the Screentogif application if you don’t have one yet.

1 Like

Hi @DaVince,

although I can’t reproduce it myself I think you ran into an effect where there is a selection active but empty so it prevents every pixel change.
It happened to me when using the rectangle selection tool along with the option “Extended edit” enabled and changing to another tool before finalizing the selection.
Maybe something similar happened with you. The problem I mentioned will be fixed with V8 Beta5.


1 Like

Hi! I took a little while to respond but jan, what you describe is pretty much what happened. I don’t have Extended Edit on, but switching from the selection tool to any drawing tool is enough to have the draw tools not work because there is no selection.

To demonstrate what exactly I’m doing, I’ve recorded a small video.

I don’t consider this that much of a bug but perhaps more of unexpected behavior. :slight_smile:

Hi @DaVince ,

what you are showing is another bug. Need to fix that, too.


Fixed with V8 Beta 5

1 Like

Thank you very much!