Sometimes pressin shortcut D will go to paint dotted and no paint line

As the title say, sometimes when i am drawing changing between tools or just pressing D by accident will make the tool go to Paint Dotted and no Pain Line.

The random of this bug make me impossible to pin point it or make a video out of it. Can be possible that i press the S key by accident so i am deleting that shortcut for now.

Hi toto,

I couldn’t reproduce your problem. I suspect maybe you forgot to reset your settings into something you’re familiar with? I usually get hit with this when i forget to re-set the Dot Space param:

Hope it helps!

1 Like

Hi @cageburner i realice that the problem i was having its that after doing the “Rectangular Brush Tool” it will auto-select the paint dotted tool, i not like this feature :sob:…it will be cool if you can select what tool to go after using the “Rectangular Brush Tool” :smile:

So btw its not a bug

Hey toto,

By ‘rectangular brush tool’, did you mean this (square/rectangular pixel brush?):
image

Or this (rectangular tool(s)? ):
image

I can’t seem to replicate your issue where another tool is selected while selecting a totally different tool.

Same with the rectangle tool, I’ve set both tools’ relative tools use the same kb shortcut like so:
image
Even so, it’s not selecting another tool when i don’t want to.

I can only speculate for now that:

  • Maybe your keyboard buttons are getting stuck sometimes?
  • Or that you’re unknowingly pressing the other shortcut key whenever you press the kb shortcut?
  • Or that the kb is somehow electrically shorting out and pressing another key, instead?

The only way to test this is if you have another keyboard lying around to plug in your pc.

Hi check the following gif, you can see that i have the paint tool selected and after i use the Rectangular Brush Grab Tool i set it to Paint Dotted Tool.

pmotion_yWfvVs7rzF

I see, thanks for the demo gif.
Here’s what you’re looking for:

(As of version 8.0.9.1, also works for 8.0.7)
Go to the Menu bar, then: File > Preferences

Under the Miscellaneous tab, uncheck the first item which should read: Activate single Dot Paint tool after Brush Capture or Container Pickup

Now, try to select a drawing tool like line, or rectangle, then do a brush grab.
Should work like a charm now. :slight_smile:

Thanks you for the help !! :grin: :grin:
i am going to use this setting from now on!