V8 crashes almost immediately in Parallels + Windows 10

So I finally decided to give the latest version a try (8.0.0.10, 2023-01-15) and almost immediately ran into issues.
First of all, I got the following Windows errors:
vcruntime140_1.dll was not found

Managed to circumvent that one by installing a new/updated version of Visual Studio.

Next I got several times an error that the system font could not be loaded.

I also noticed that the DPI scaling of the app was significantly changed. It had become so high-res that the UI was incredibly tiny. Pretty much unusable on my 16" MacBook Pro.
I couldn’t find of a way to change it because I’m getting constant crashes, pretty much immediately after the app has opened. Sometimes without me even clicking on anything.

So yeah… seems like V8 is not ready quite yet for Mac users.

Jan, please let me know if you need me to provide you with any additional information that can help you making stability improvements for the Mac.

Hi @DutchDimension

hmm, I don’t even use vcruntime :confused:
Can you please install the latest V7? Does this work?
When it crashes, do you get a crash report window that allows storing a bug report? The built in crash handler should offer that.

When you started the version you should have gotten a kind of initial set up dialog where you can also select the kind of DPI scaling. Did you set something up there?
You also find this setting in the Preferences section “Combatibility”.
What DPI scaling did you set up in the Windows display settings?

-Jan

Hi Jan,

thank you for the reply.

I’ve just installed the latest non beta version, v7.2.8.0, and it is working properly. No crashes.

When I launch the beta, I have only a few seconds after the GUI appears to do something before it crashes. It will crash 100% of the time within 5-10 seconds. I do not see any crash report window. The Pro Motion window simply disappears.

At first start up there was indeed a window in which some options were presented, but likely due to the missing system font error, the text was heavily cropped which meant I could not read the various options properly. So I likely did not set the DPI scaling up correctly. If there is an option within Pro Motion’s preferences then that’s fine too. I just can’t get there fast enough before the app crashes again.

Hope this further information.

This is a screenshot of the GUI just before it crashes.
As you can see, it came in very small, especially for a 16" MacBook Pro screen.

Gonna try updating macOS to the latest Ventura. And update my version of Parallels to v18 (up from v15). See if that helps.
Fingers crossed it doesn’t break v7.

Okay, a couple of days have passed and I got around to upgrading my OS to the latest version, as well as updated Parallels Desktop to the latest version.
Unfortunately this does change the behaviour of the Pro Motion NG beta.
I still get the ‘System font could not be loaded!’ error.
And it still crashes 100% the time as soon as I try and do anything.

I hope a fix can be found for this as I really want to test out the new v8 additions.
Jan, please let me know if there is anything I can do to help you solve this.

ps. v7.x continues to work totally fine.

There is a problem that normally leads to ‘System font could not be loaded!’ when starting the first time. This is because the system font is copied to the place where PM expects it, after PM tries to load it from that position :clown_face:

But that it’s not working when you start it the second time, tells me that this copy operation also did not work.
Do you have a folder like c:\users<your username>\documents\Pro Motion NG - beta ?
It’s strange that you don’t get the dialog of the crash handler that’s included :frowning:
What happens exactly when it crashes? Do you get any error message? Or is it getting stuck? Or does the program just close?

As for the UI scaling I need to explain what happens.
With V8 I support true UI scaling (if set up correctly). But the UI scaling stuff is a hassle in Windows (and the dev system I use), although it improved the last years.
V7 has a definition within its executable that tells Windows that it does not support UI scaling and Windows should handle this on it’s own. By default Windows then uses a bi-linear upscaling. That means, every UI window element is scaled up making it slightly blurry. You should have that effect.

With V8 the executable says: "hey, my UI can basically be scaled, please use ‘per monitor scaling V2’ ".
“Per monitor scaling V2” is the most recent scaling method and means: when you have different monitors with different scaling settings and you move windows of the application between them, its contents will be renewed/resized with the scaling set up for the respective monitor.
Scaling means that the elements are actually drawn larger, using larger fonts, etc. . The dev system I use has some flaws there, but they don’t really matter, they are minor as far as I could test.

Now, what’s the problem?
The problem is that yet I didn’t trust the scaling and also wanted to give options. So, although the executable says: I’m scalable (which is required to use scaling options at all), I switch scaling off by default when starting the application, or, more precisely: it switches to the setting the user picked and “no scaling” is the default (at the moment). That’s why it’s unscaled on your system. But this is buggy with some systems (although it works on mine):
image
Checkboxes are upscaled, and some text is, too (e.g. the news pane), although I said: don’t scale. This happens on my new Windows 11 test system as well.
The bi-linear scaling (when explicitly set up) also does not work on my Win 11. It stops drawing some windows, leaves artifacts on screen etc. . :frowning:

To make a long story short on this… if you wouldn’t face the crash then you could go to the preferences and set up “high DPI scaling” and everything would be fine.
Since my way to offer different scaling options is not working (on all systems) I will deactivate that and so UI scaling will always be enabled. It will of course only scale anything if the Windows display settings are set up to scale larger than 100%. Then the user would not need to change anything in the prefs but you also would not be able to use the type of scaling (bi-linear) that PM V7 used as described above.
It’s a pity that I face these problems so close before the V8 release, but I hope that the scaling will work as expected. Let’s see.

Of course all this is nothing a user should be bothered with, but I wanted to explain the effects that you have with the tiny UI elements.
The bigger problem is the crash behavior and I hope that we can find the reason. I don’t think that this a problem specific to Parallels only. It might also happen on “true” Windows machines.

Thanks for your support!

By the way… you also commented here: Feedback on new PMNG beta (64 bits) on MacOS M1 (Monterey)
Would it also be possible for you to try out Wine and running PM with that? Although it starts with bright UI skin you should be able to switch to “dark mode” in the prefs. The dark mode did not work well in the past, but I did not do any checks on that with V8 and the most recent Wine versions. (I don’t have a Mac myself, actually :slight_smile: )

1 Like

I found the problem concerning the missing DLLs. Some DLL I created had some dynamic dependencies instead of using static linking (including all the binaries it needs directly). This is now fixed.

1 Like

Thank you for the in depth communication Jan.

Let’s see…

Do you have a folder like c:\users\documents\Pro Motion NG - beta ?
I have the following folder structure (slightly differently capitalised):

C:\Users\dannygeurtsen\Documents

But inside there is no ‘Pro Motion NG - beta’ folder. In fact, the Documents folder is completely empty.

What happens exactly when it crashes?

The application just disappears. No warnings, no pop-up windows of any sort. The only indication I could notice was that just prior to the crash, the windows cursor briefly shows a blue circle (see image), twice.
images

Then pop… the program is gone.

That means, every UI window element is scaled up making it slightly blurry. You should have that effect.

Correct. I can see this with V7.

Would it also be possible for you to try out Wine and running PM with that?

So I tried running PMNG beta via CodeWeavers Crossover. It seems to work. But the PMNG window is stuck in the top left corner. I cannot resize the window nor move it. It is also only showing part of the GUI.

(I don’t have a Mac myself, actually :slight_smile: )

I hope you can acquire one at some point. It would help support the macOS users run PMNG. Also, they’re really nice machines. :smiling_face:

Hi @DutchDimension,

can you please check if this temporary patch crashes as well?

Just copy the files from inside the zip into your beta folder and overwrite the ones that are there.
Still I have no idea what the issue can be, but I fixed the this concerning the required VC-runtimes. Maybe they caused that :man_shrugging:

-Jan

Hi Jan,

good news. Looks like you fixed it. No more crashes. Hooray! :grin:
I’ll start testing v8 in earnest now. Do you have any date in mind for when you want to have release candidate? Just so I know by when to get bug reports/change requests in.

Many thanks!

Actually the release should already have been done, but being a weekend time project, predictions are useless.
But the next weeks it should be there. I focus on bugs now and of course after the release there will be regular updates and fixes.

One thing I forgot to mention is that I am still seeing the ‘System font could not be loaded!’ warning upon starting the app.

Yes, I forgot about that topic. You wrote that C:\Users\dannygeurtsen\Documents is completely empty. This is weird. It’s even more weird that, when PM starts then it checks if it can write there. If not then it displays a message and quits. So, it seems that write operations are swallowed and when reading, nothing is there.
Can you store a txt file there created with Windows Notepad?

Just tried it and yes, I can.

This is so weird. And with V7 this does not happen, right?

Correct. It doesn’t happen with V7.x.

But the thing is, even V7 creates this folder and relies on it (without the " - Beta" ind the folder name of course) :thinking:
So, I wonder where PM 7 loads the font from (as well as project templates, dither patterns, bitmap fonts…).
Can you search the system for a file called “project.presets.cfg”?

Okay. I solved it, with your help.

Here’s what I did.

I did a search in Windows 10 (running under Parallels Desktop) and found a project.presets.cfg in this location:
C:\Program Files (x86)\Cosmigo\Pro Motion NG
That’s the only file Windows 10 search finds.

I decided to also do a search in macOS itself for this file. And it found these two locations.
/Users/dannygeurtsen/Documents/Pro\ Motion\ NG/project.presets.cfg
/Users/dannygeurtsen/Documents/Pro\ Motion\ 8/project.presets.cfg

In these two locations there is the usual list of folders and files one would expect. However, the /fonts folder in the ‘Pro Motion 8’ parent folder was empty. So I copied the files from the ‘Pro Motion NG/fonts’ over. Now there is no longer an error.

I’m really not sure what would’ve caused an empty /fonts folder initially.

Where did you unzip the beta to?
Also this folder must contain a sub folder “fonts” and on startup its copied to documents/Pro Motion…