• jan@cosmigo.com

Win 10 Creators Update: PM-NG Won't Start

After Windows 10 Creators Update (1703) Pro-Motion NG (v7.0.10) hangs forever at the splashscreen (x64 machine). So I can’t open PM anymore.

I’ve checked the (third party) firewall settings and they are alright (it does log PM connecting to the Internet) — and it used to work fine before the update.

I’ve tried reinstalling it, but nothing changed.

Has anyone else experienced this problem with the Creators Update?

Does it log that it finished the connection or is it still trying to load something from the net and this process does not end?

Yesterday my firewall prompted me about pmotion.exe trying to connect to the internet, and I allowed it and made a rule for it (NOTE: Win 10 Creators update reset all my previous firewall rules, so I’m rebuilding them).

Today I’ve uninstalled and reinstalled PM, and tried to run it a couple of times. It still hangs at the splashscreen, but I don’t see any logs in the firewall history. So it seems that right now is failing even before trying to connect to the Internet. I also checked all logs of the antivirus/firewall, but no logs mention PM (except for yesterday, as mentioned)…

Yesterday, on a couple of attempts I noticed that in the lower Windows Icons bar, beside the splashscreen,also the main UI thumbnail would show up when overing over PM icon — but only a couple of times, most of the time I only get the to see the splashscreen thumbnail when overing. So my impression (from this and from the lack of firewall log today) it seems that it’s not a single point of failure, but that it gets stuck at different points of execution.

Something changed with this Win update, but I’m not sure what.

Does PM rely on .NET? With the Win update there was also some major update to the .NET framework.

I’m trying to work out what tests I could do to isolate the problem, but can’t think of any. Disabling the firewall didn’t work. I’ve tried to run it in compatibility mode, but that failed too.

Any ideas?

PS: I have a Wacom Intuos tablet (currently disconnected), and a display color calibration tool (active).

Does PM carry out any checks on such devices at startup? Maybe there could be a new drivers issue.

This is a screenshot of the mouse-hovering thumbnails I mentioned:

… here you can see that there is also a second window associated with the PM process (the main UI), which is the one hanging now. But tabbing through the open windows only shows the splashscreen, and never the main UI.

Most times I only get the splashscreen, but about once in every 10 tries I also get the second thumbnail by hovering over the PM icon. When this happen, the hangin window becomes the main UI. So at times the splashscreen does seem to make it through. In both cases, I don’t see anything in the firewall log.

It’s a strange problem. And I’ve also discovered that some other apps fail to start after the update (eg: Photoshop 7, x32). Overall, most apps are working all right, but some fail by hanging at startup.

Can you try deactivating update checks?
To do this, please set HKEY_CURRENT_USER\Software\Cosmigo\Pro Motion 7\Preferences\checkForUpdates to 0 using regedit.

Tried: still hangs.

I’ve been looking at pmotion.exe with Process Explorer and Process Monitor. I can see that the process has threads hooking to the Wacom Intuos and (strangely) also to OmniPage Pro (OCR software).

These are some lines extracted from Process Monitor log file (two different sequences extracted):

"15:29:02,8214945","pmotion.exe","9688","Load Image","C:\Program Files (x86)\Common Files\Microsoft Shared\Ink\tiptsf.dll","SUCCESS","Image Base: 0x6aaa0000, Image Size: 0x80000"
"15:29:02,8231919","pmotion.exe","9688","Load Image","C:\Program Files (x86)\ScanSoft\OmniPagePro12.0\ophook12.dll","SUCCESS","Image Base: 0x1320000, Image Size: 0x28000"
"15:29:02,8237411","pmotion.exe","9688","Load Image","C:\Program Files (x86)\ScanSoft\OmniPagePro12.0\ophook12.dll","SUCCESS","Image Base: 0x1320000, Image Size: 0x28000"

"15:29:02,8657700","pmotion.exe","9688","Load Image","C:\Windows\SysWOW64\Wacom_Tablet.dll","SUCCESS","Image Base: 0x60730000, Image Size: 0x1bb000"
"15:29:02,8671092","pmotion.exe","9688","Thread Create","","SUCCESS","Thread ID: 11768"

Since also Photoshop hangs, I think they have in common some problems with device drivers for scanners, tablets, or some other TWAIN tools. This is the only reasonable link I can see for PM process loading an image from Omni Page.

I’ve reinstalled and updated all my Wacom drivers (Intuos 5 and Inkling) and softwares. Also the Display Color Manager is updated.

I’ve killed the opware.exe process that starts off the ophook12.dll, but PM still hangs.

I can’t manage to kill the Wacom process though, so I didn’t manage to see if it works without the Tablet software/drivers going.

Googling, I’ve found some complaints that after Win 10 Creat. upd. some apps don’t work properly, and most of these reports pertain to Adobe products related to graphics. This seems to confirm that the issue has to do with changes in the area of graphic editing (tablets, etc).

Some people experienced issues with the nVidia drivers (accelleration and physics being disabled), but I cheked that with GPU-Z and all seems in place (the nVidia driver and software are up to date).

I don’t know if any of this is helping you isolate the problem. I’m trying all I can to understand where the issue might be coming from, but I’m having a hard time figuring out which way to go.

PM loads the wintab32.dll to access tablet functions. If you rename it to wintab32.dll_ then it can’t be loaded. Should be somewhere in the Windows folder.
Other dlls are loaded by the runtime system I use. I don’t what is done in detail and why. I son’t know why scanner dlls are loaded, but is this maybe a combined scanner and printer?
Printer devices are detected when starting up PM. Maybe you should do a clean uninstall of printer-/tablet-drivers and see if its gone then.

I’ll try the wintab32.dll solution. I’m considering a full OS reinstallation, but I first need to asses how many programs were affected by this update and if the pain is worth the gains. So far I’ve only found a few programs stuck.

I’d like to know if others have experienced the same problem with PM and Creators Update.

Has anyone updated to Creators (1703) with Pro Motion installed? Did you experience problems? or is everything fine?

Win 10 Pro 64-bit with Creators Update and Pro Motion works fine for me.
Haven’t had an issues with Creators Update except all the Windows Store and Apps nonsense is broken, which is mostly a good thing.

Renaming wintab32.dll didn’t make PM start.

@surt: Thanks for letting me know, so now I know that a fresh Win 10 install might solve these issues. I was hoping to avoid reinstalling the whole OS — I’ll loose some licenses that were bound to the machine lifetime only (antivirus, ecc.), and of course all the custom settings are going to be a nightmare. I also have an Ubuntu partition, and this won’t make things any easier.

Probably I’ll get a new hardrive and install all the OSs’ there, so I can also temporarly keep the current Win 10 as a boot option — it will help to peek around previous settings and avoid loosing stuff. And most of all it will not force me to do everything in a rush.

I’ll take this as a chance to finally get a solid state hard drive for the OSs’ and gain some speed and full sepration between OSs’ boot drive and actual data (instead of just partitions). I might keep the current partition for installing outdated software and testing new apps while keeping the new Win 10 clean with strictly required working tools.

Right now I’ve managed to install PM in a virtual machine with XP running. It works (slower, but it works).

This is far from an ideal solution (XP being obsolete, I block any internet traffic on the VM), but at least I can open PM and recover all my work and export it to standard images and from there take on with some other Pixel-Art software.

Getting a new SSD hard drive and a fresh Win 10 installation is definitely on my list, but it won’t happen anywhere before Christmas 2017 or the beginning of 2018 — too much time and money involved, and right now I’m stuck with some work I need to finish on the current machine. Also, I don’t see so many applications affected by the update. So I’m afraid I won’t be enjoying Pro Motion until then, and have to fallback on some other tool to carry Pixel-Art work.

In the meantime, I cross fingers and hope that one of the next PM releases will work on my system as it is — with MS Windows you never really know how things can turn out: from “ground-breaking” updates like this Creator stuff (which broke so many PC and software rather than breaking any technological grounds) to mysterious bugs that come and go, chances are that further Win updates might fix the problem (whatever and wherever this might be).

I’ll keep an eye open for the culprit (check devices and their drivers, and for the presence of any broken software in the system), but I seriously doubt I’m gonna find a fix for this — and I can’t spend more than so much time on this right now.

Microsoft really made a huge mistake with this “Creators” update: Google is packed with complaints, including people who lost the whole OS. I was relatively lucky, after all, my OS still boots.

All this is really annoying … I was even working on a plugins project for Pro Motion NG, but I’ll have to freeze it for now.

Whenever new releases of PM-NG come out I’ll try to install them and post on this thread some feedback. Meanwhile, thank you for your support.

Well, PM does not do any mysterious thing on startup, but it e.g. checks for printer devices. At the moment I don’t have the Creators update and if I had it then it’s not probable that I have the same problems,
My advice still is:
Completely uninstall Printer/Scanner and Tablet drivers. Then try to start PM. Does it start? Does Photoshop or x32 run?
This would be the way to go because it does not harm. You can reinstall those drivers easily and maybe the problem is gone then.

Also I could provide a patched version that does not load the printer drivers to see if it’s gone then. Write by email if you want me to do so. It’s not a big deal.

I finallty managed to get the scanner back on the table and do some tests: Something is wrong with the scanner software.

My previous scanner was a Plustek OpticBook 3600 Corporate, then it broke and I bought a Plustek OpticBook 3800 — the 3800 model being the next generation of the same type.

For the old 3600 there were only some very old drivers (Win 98/XP SP1) so I had to force-install them on the system (Win 7 originally). Then I updated to Win 10. The drivers and software of the 3600 are still in the Programs x86 folder, and they can’t be uninstalled (it raises an “OS incompatiblity” error).

The new scanner, the 3800, is a recent aquisition, and it came with up-to-date drivers (Win10), so I just installed all the drivers and software ignoring the previous model. And it always worked good … until the Creators Update.

Now the main scanner utility doesn’t start (I can’t even see the process in the background).

I’ve uninstalled the driver (and tools) and reinstalled it. Nothing changes. I’ve got the most recent drivers available for it.

The thing is that Windows does see the scanner correctly (at least the model show up right) and it can’t find any driver updates from MS. The old 3600 doesn’t show up in the devices, I think it’s just a dead folder left behind (don’t think this is the reason for the failure).

The scanner came with a CD Rom that installed some other tools. The bad think is that it doesn’t allow re-installing the software, nor uninstalling it: it keeps saying that everything is already installed and offers no further options. So I guess I have to handle this manually.

Ok, I’ll need some time to test with this. I’ll try to uninstall everything that came with the scanner (drivers and tools) and see if PM and Photoshop work without them. And then I’ll try to see if I can get the scanner to work.

SOLVED!!!

It wasn’t the scanner … it was Omni Page, the OCR software — as I though from the start, due to that opware.exe process.

Don’t ask me why, but Omni Page was blocking anything relating to scanners. When I tried to uninstall it, the uninstaller told me that in order to proceed I’d have to close a long list of applications and process — including the antivirus, the virtual machine software, and a very long list of processes. This opware.exe process was basically hooking all around the system.

Now PM, Phtoshop 7 and the scanner work fine!

True, it was an old version of Omni Page (v 12), but up to now it served me nicely and I really liked it. Now I’ll have to change OCR software, and use the ones that came with the new scanner.

So, it ended up well, luckily! (but I’ll still go for a new SSD-HD and fresh OS at Christmas, I don’t like an OS like this, that has been dragged around too long with major updates).

Thank you :heart: for all the support abd time that you’ve dedicated me! You were both very kind.

… and now I can get back to work, with my images and the PM plugins as well! :grinning:

Congratulations. I’m happy that you solved the problem. :thumbsup:

I’m having the same trouble. If I do a fresh reboot, start Pro Motion NG, it will run. If I close program and reopen, I see in the task manager but it never loads. If I kill it and try again, it still won’t load. I’ve registered so it’s a bit distressing to not be able to use it.

From what you described, it seems that the problem is due to the application not closing correctly. This might be caused my many different problems, including drivers incompatibility, or even PM plugins. The fact that you can only launch PM on a fresh boot indicates that some process didn’t close properly, so that’s the direction you should be investigating.

If you have any PM plugins, you should try to disable them, just in case the problem is with a plugin not being released correctly.

Windows’ Task Manager might not be enough to track the problem, you should download some specific diagnostic tools from Microsoft’s Windows Sysinternals tools:

They are free and standalone tools, just unzip and launch them.

There are various process-related tools you can download:

I advise you to get Process Explorer and Process Monitor to start with. They are nice GUI tools to track which resources are launched by an application, and they will allow you to visually check if any resources (e.g. a PM plugin, or a driver) are not being closed when the process is killed.

Also, you can use these tools to kill the whole process tree, which would allow you to spot which asset is “hanging” after you close PM the first time, which is most likely the culprit which is preventing further PM launches.

By using the sysinternal process-tools, like ProcDump and ListDLLs, you should be able to create detailed reports of your Windows’ process states before, during and after PM execution, which you could then send to Jan to allow him track the problem.

Just a couple of points:

  1. Pro-motion did quit properly when run, when it fails to load there’s no previous pro-motion executable running
  2. I have no PM plugins (unless there’s default ones)?
  3. I have a .dmp file that I created from VS, I attached debugger, paused and saved the dump. If there’s a private email (or something), I will send a onedrive link to the dump file [don’t want to post that public]
  4. See below for DLLs loaded (taken from VS)
  5. Windows Version 10.0.19042 Build 19042

.

'pmotion.exe' (Win32): Loaded 'C:\Program Files (x86)\cosmigo\Pro Motion NG\pmotion.exe'. Module was built without symbols.
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ntdll.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\kernel32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\KernelBase.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\comdlg32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvcrt.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\combase.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\mpr.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\winspool.drv'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\wininet.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ucrtbase.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\rpcrt4.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\SHCore.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\user32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\win32u.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\gdi32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\gdi32full.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvcp_win.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\shlwapi.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\shell32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.19041.488_none_11b1e5df2ffd8627\comctl32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\oleaut32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\advapi32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\version.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\sechost.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\oledlg.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ole32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\netapi32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Program Files (x86)\cosmigo\Pro Motion NG\libeay32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Program Files (x86)\cosmigo\Pro Motion NG\math.dll'. Module was built without symbols.
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\avifil32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ws2_32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\shfolder.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\wsock32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\winmm.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvfw32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msacm32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\winmmbase.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Program Files (x86)\cosmigo\Pro Motion NG\complib.dll'. Module was built without symbols.
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\netutils.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\imm32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\Faultrep.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dbghelp.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dbgcore.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ntmarta.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\uxtheme.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msctf.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\kernel.appcore.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\bcryptprimitives.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\wtsapi32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\winsta.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\security.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\secur32.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\sspicli.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\hhctrl.ocx'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\riched20.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\usp10.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msls31.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\windows.storage.dll'. 
'pmotion.exe' (Win32): Loaded 'C:\Windows\SysWOW64\wldp.dll'. 
The thread 0x5ec8 has exited with code 0 (0x0).

As you can read from my old posts in this thread, for some reason PMNG was being blocked on my machine by an OCR software, just because of the commonly shared scanner drivers. So there must be some assets which are left hanging after shutting down PMNG, and which prevent its initialization on further launches. Identifying which assets it is might be tricky and require some trial and errors with process monitoring tools.

No, PM doesn’t ship with any plugins natively.

Good idea not to publicly post dumps, it would be unsafe. You should arrange with Jan what type of dump info he might need to look into it — let’s buzz him by mentioning his username: @jan.cosmigo — this should call his attention to this thread.