• jan@cosmigo.com

Lock axis shortcut wont work


#1

Hello all,

After updating to version 7.2.3.1 I noticed a pretty annoying issue.

Holding the shift key to lock the brush on either horizontal or vertical axis sometimes stop working.
It seems to occur when booting Pro Motion and reloading a saved session but I’m not too sure.

When the bug appears, rebooting Pro Motion, with or without reloading my session won’t make it go away.
The only workaround I found was rebooting my computer. You can understand how tedious that is.

Does anyone know about this issue ? Did I do something wrong in my settings ?

Cheers.


#2

Hi @Nikuichi ,

I will try to duplicate the issue but I have some doubt that it’s possible.
The weird thing is that it goes away when you reboot! This sounds like a system dependent issue.
But let’s go through it step by step:

Please make sure you have the license key file. If not then go to menu “Help/Licensing Information” and export the key file.
Start regedit (registry editor) and delete the following “folders”:
Start Pro Motion again and import the license key.

Questions:
When it does not work you can clearly do the following steps?
Restart PM
Create a new animation project of 500x500 in size.
Select “Paint continuous” tool.
Move the mouse on the canvas to see the single pixel brush moving.
Use Zoom level of e.g. 10
Hold left Shift move the mouse slightly to the right and then move it up.
The pixel brush does not stay on the horizontal position but moves up?

-Jan


#3

Hello Jan,

I tried both registry and creating a new project but neither seem to have an impact on the issue.
Also I didn’t say earlier but when it occurs, my shift key works perfectly everywhhere outside Pro Motion.

RV


#4

For general information: In the meanwhile it turned out that the special multi button mouse along with its settings software seems to cause the problem. Still it is not clear why it only happens within Pro Motion.


Left click treated as right click
#5

Just adding that I’ve also experienced this in version 7.3.2.1 (Windows 10), but only one time so far. Holding SHIFT while using the Brush Tool didn’t lock to X or Y.

Tried exiting and restarting Pro Motion but the issue persisted.
The next day it was fine. I don’t recall if I had rebooted my computer.

Will update here if I figure anything out.


#6

Hi @mathias,

do you have a multi button mouse that comes with more than 5 buttons?

-Jan


#7

Yep, sure do. I use a Logitech Performance MX mouse.


#8

That would be the same exact mouse I have.


#9

So, it’s likely that the driver system this mouse uses has some strange effect to Pro Motion, but it’s strange that it does not happen to other programs!?
Do keyboard shortcuts that use Shift still work while Shift-axis lock does not?

@nickwoz: do you use the same mouse?


#10

If it happens to me again, I’ll mess around with my Shift keys and see if I can figure anything out. If I do I’ll report back to this thread,


#11

Hey.

If we’re both having the issue, it should be easy to reproduce.

I just had to use one of the customizable buttons on my mouse. I used it to play / pause videos and as soon as I pressed it, Pro Motion would stop registering the shift key.

It does not matter if Pro Motion was opened beforehand. It does not matter which button I map this function to.

If I ever use it at one point, it would trigger the issue until I reboot my computer.

2020-02-10_11h28_04

I was using this particular button the first time it happened if it is of any help.
Also, when the issue triggered, it ONLY triggered for Pro Motion. I could still use the shift key to select multiple folders in the Explorer for instance.


#12

When you trigger the button and Shift-lock does not work anymore… do keyboard shortcuts that involve Shift still work?


#13

Hey Jan,

Just tried it out. When I repro the issue, only shift-lock stops working.
I have shift + Z bound to brush resize and it worked just fine.

Hope that helps somehow.


#14

Can confirm this issue still happens in version 7.2.4.0.
Seemed totally random, no idea what triggered it to happen.
Quitting and re-running Pro Motion didn’t fix it. Had to restart computer.


#15

It’s connected to the special mouse button to “play / pause videos” as mentioned by @Nikuichi and after exchanging a special patch creating a log file I now know the reason.
The Shift lock checks if Shift is the only key that is pressed. As soon as another key is in use it stops locking. This is done to not interfere with other key shortcuts.
As soon as you use the mouse button in question then the system says that another key is permanently down: “volume up key” :roll_eyes:
Obviously this is until you reboot.
That’s why it’s not working. Of course the lock feature would not have to check if ALL other keys are up but this was the simplest way. I will have to limit the keys now that are checked. This is possible and I’ll fix this asap.


#16

Oh you know what - when it happened to me yesterday my pause/play button on my keyboard stopped working at the same time Pro Motion stopped registering the Shift key to constrain axis. But I guess you’ve got the issue pin-pointed already.
When I restarted, both my keyboard pause/play button not working to control my music player app and shift constrain not working in Pro Motion were both solved.

In case useful, I use a Microsoft Comfort Curve 2000 keyboard:


#17

So the problem really seems to be caused by the special mouse extension software and it’s not only affecting PM. Good to know.